<html><head><meta http-equiv="Content-Type" content="text/html charset=us-ascii"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div><div class="im"><div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; ">We have identified an issue in Riak 1.4.0 that will cause any node hosting Riak Control to crash during a rolling upgrade. It is triggered when Riak Control attempts to communicate between a Riak node running version 1.3, or earlier, and one running version 1.4.</span></div> <div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; ">If a customer were hosting Riak Control on all of their nodes, this could result in a cluster-wide failure.</span></div> <div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; ">If you are using Riak Control, you have two options:</span></div> <div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; ">1) Wait for Riak 1.4.1. We anticipate releasing this update by the end of this week.</span></div> <div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; ">2) Riak Control must first be disabled on all nodes in the cluster.  To do this you must edit the app.config and restart Riak[0] on every node running Riak Control in the cluster. Once disabled, proceed with a standard rolling upgrade to Riak 1.4.0[1].  After the entire cluster is upgraded to 1.4.0 you may then safely re-enable Riak Control on the node(s) which you'd like to run the web interface.  Again, this is done by editing app.config and restarting[0] the node(s).</span></div><div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; "><br></span></div></div><div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; ">If you have any questions about upgrading to 1.4.0, please contact <a href="http://mkto-g0163.com/trk?t=2&mid=NzIxLURHVC02MTE6Nzk3OjA6MDowOjk0MjowOjA6YWlzaGlrYXdhQGJhc2hvLmNvbQ%3D%3D&&&mailto:help@basho.com?mkt_tok=3RkMMJWWfF9wsRow5%2FmYJoDpwmWGd5mht7VzDtPj1OY6hBEqIKrcLUPfmtZXFYpvZ%2BiNCQ0%3D" target="_blank">Basho support</a> to assess whether or not you should wait for the 1.4.1 release.</span></div><div><span style="font-family: arial, helvetica, sans-serif; font-size: 12px; "><br></span></div><div><span style="font-size: 12px; font-family: arial, helvetica, sans-serif; ">Basho </span></div><div><span style="font-size: 12px; font-family: arial, helvetica, sans-serif; "></span><br class="webkit-block-placeholder"></div><div><span style="font-size: 12px; font-family: arial, helvetica, sans-serif; ">[0] <a href="http://mkto-g0163.com/trk?t=2&mid=NzIxLURHVC02MTE6Nzk3OjA6MDowOjk0MjowOjA6YWlzaGlrYXdhQGJhc2hvLmNvbQ%3D%3D&&&http://docs.basho.com/riak/latest/ops/advanced/riak-control/?mkt_tok=3RkMMJWWfF9wsRow5%2FmYJoDpwmWGd5mht7VzDtPj1OY6hBEqIKrcLUPfmtZXFYpvZ%2BiNCQ0%3D" target="_blank">http://docs.basho.com/riak/latest/ops/advanced/riak-control/</a></span></div><div><span style="font-size: 12px; font-family: arial, helvetica, sans-serif; ">[1] <a href="http://mkto-g0163.com/trk?t=2&mid=NzIxLURHVC02MTE6Nzk3OjA6MDowOjk0MjowOjA6YWlzaGlrYXdhQGJhc2hvLmNvbQ%3D%3D&&&http://docs.basho.com/riak/latest/ops/running/rolling-upgrades/?mkt_tok=3RkMMJWWfF9wsRow5%2FmYJoDpwmWGd5mht7VzDtPj1OY6hBEqIKrcLUPfmtZXFYpvZ%2BiNCQ0%3D" target="_blank">http://docs.basho.com/riak/latest/ops/running/rolling-upgrades/</a></span></div><p><a href="http://mkto-g0163.com/trk?t=2&mid=NzIxLURHVC02MTE6Nzk3OjA6MDowOjk0MjowOjA6YWlzaGlrYXdhQGJhc2hvLmNvbQ%3D%3D&&&http://docs.basho.com/riak/latest/ops/advanced/riak-control/?mkt_tok=3RkMMJWWfF9wsRow5%2FmYJoDpwmWGd5mht7VzDtPj1OY6hBEqIKrcLUPfmtZXFYpvZ%2BiNCQ0%3D" target="_blank"></a></p></div><div class="im"><img width="1" height="1" border="0" alt=""></div><div>
<div><div>-John Daily</div><div>Technical Evangelist</div><div>Basho</div></div>

</div>

<br></body></html>