<div dir="ltr"><div><div>Hi Siddhu,<br><br></div>Can you try changing 'cs_proxy_host' to localhost? So:<br><br> {cs_proxy_host, "127.0.0.1" }.<br><br></div><div>and retry.<br></div><div><br><br></div></div>
<div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Oct 9, 2013 at 9:55 AM, Siddhu Warrier (siwarrie) <span dir="ltr"><<a href="mailto:siwarrie@cisco.com" target="_blank">siwarrie@cisco.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



<div style="word-wrap:break-word">
<div style="font-size:14px;font-family:Calibri,sans-serif">
Hi,</div>
<div style="font-size:14px;font-family:Calibri,sans-serif">
<br>
</div>
<div style="font-size:14px;font-family:Calibri,sans-serif">
I have a two node Riak CS (1.4) cluster set up on two nodes (node-1 and node-2 henceforth). Node-1 is the headnode. Both node-1 and node-2 are running CentOS-6.4.</div>
<div style="font-size:14px;font-family:Calibri,sans-serif">
<br>
</div>
<div><font face="Calibri,sans-serif"><b>N</b></font><b style="font-size:14px;font-family:Calibri,sans-serif">ode-1</b></div>
<ul>
<li>Riak 1.4.2</li><li>Stanchion 1.4.1</li><li>Riak-CS 1.4.1</li><li>Riak-CS-Control 1.0.2</li></ul>
<div style="font-size:14px;font-family:Calibri,sans-serif">
<font style="font-size:medium" face="Calibri,sans-serif"><b>N</b></font><b>ode-2</b></div>
<div style="font-size:14px">
<ul style="font-family:Calibri;font-size:medium">
<li>Riak 1.4.2</li><li>Riak-CS 1.4.1</li></ul>
<div><font face="Calibri,sans-serif">I have got Riak CS working, and have created admin credentials that I've set correctly on stanchion, riak-cs, and riak-cs-control on node 1, and on riak-cs on node 2. I am able to use the admin credentials to perform operations
 on the bucket using </font><font face="Consolas">s3cmd</font><font face="Calibri,sans-serif">.</font></div>
<div style="font-family:Calibri,sans-serif"><br>
</div>
<div style="font-family:Calibri,sans-serif">However, when I try to list riak-cs users using the riak-cs-control, I get no results. The error that comes up in /var/log/riak-cs.log is:</div>
<div style="font-family:Calibri,sans-serif">
<pre style="font-family:Menlo,Monaco,Consolas,'Courier New',monospace;font-size:0.923em;line-height:1.583em;margin-top:0.731em;margin-bottom:0.731em;padding:0.654em 1em;background-color:rgb(249,249,249);border:1px solid rgb(228,228,228);border-top-left-radius:2px;border-top-right-radius:2px;border-bottom-right-radius:2px;border-bottom-left-radius:2px;white-space:pre-wrap!important;word-wrap:break-word;word-break:break-word;overflow:auto;color:rgb(51,51,51)">
<code style="font-family:Menlo,Monaco,Consolas,'Courier New',monospace;font-size:0.923em;line-height:1.583em;margin:0px;padding:0px;background-color:transparent;border:none;border-top-left-radius:3px;border-top-right-radius:3px;border-bottom-right-radius:3px;border-bottom-left-radius:3px;white-space:pre-wrap;word-wrap:break-word;word-break:break-word">10.0.1.202 - - [09/Oct/2013:13:09:31 +0000] "GET /buckets/users/objects HTTP/1.1" 403 160 "" ""</code></pre>

</div>
<div style="font-family:Calibri,sans-serif">I also receive a 403 when I try to create an admin user.</div>
<div style="font-family:Calibri,sans-serif"><br>
</div>
<div style="font-family:Calibri,sans-serif">I saw <a href="https://github.com/basho/riak_cs_control/issues/31" target="_blank">https://github.com/basho/riak_cs_control/issues/31</a> and set my /etc/riak-cs-control/app.config file up to use the cs_proxy_host parameter as
 well, though I'm not using proxies, but to no avail. I have reproduced the relevant section of my riak-cs-control/app.config here:</div>
<div style="font-family:Calibri,sans-serif">
<div>    {riak_cs_control, [</div>
<div>       %% What port to run the application on.</div>
<div>       {port, 8000 },</div>
<div><br>
</div>
<div>       %% Instance of Riak CS you wish to talk to.</div>
<div>       {cs_hostname, "10.0.1.202" },</div>
<div>       {cs_port, 8080 },</div>
<div>       {cs_protocol, "http" },</div>
<div><br>
</div>
<div>       %% Proxy information; necessary if you are using <a href="http://s3.amazonaws.com" target="_blank">s3.amazonaws.com</a> as</div>
<div>       %% your hostname.</div>
<div>       {cs_proxy_host, "10.0.1.202" },</div>
<div>       {cs_proxy_port, 8080 },</div>
<div><br>
</div>
<div>       %% Credentials you want the application to run as.</div>
<div>       {cs_admin_key, "5VI-NIFLNIHKRNGKPBVX" },</div>
<div>       {cs_admin_secret, "xxxxxxx" },</div>
<div><br>
</div>
<div>       %% Specify the bucket name for administration options.</div>
<div>       {cs_administration_bucket, "riak-cs" }</div>
<div>    ]},</div>
</div>
<div style="font-family:Calibri,sans-serif"><br>
</div>
<div style="font-family:Calibri,sans-serif">Is there something I am missing/doing wrong?</div>
<div style="font-family:Calibri,sans-serif"><br>
</div>
<div style="font-family:Calibri,sans-serif">Thanks,</div>
<div style="font-family:Calibri,sans-serif"><br>
</div>
<div style="font-family:Calibri,sans-serif">Siddhu</div>
</div>
</div>

<br>_______________________________________________<br>
riak-users mailing list<br>
<a href="mailto:riak-users@lists.basho.com">riak-users@lists.basho.com</a><br>
<a href="http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com" target="_blank">http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com</a><br>
<br></blockquote></div><br></div>