<html><head><style>body{font-family:Helvetica,Arial;font-size:13px}</style></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">I’m trying to use the riak-erlang-client from master to talk to Riak 2.0 and I’m getting an error when I use the test commands found in the README:</div><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;"><br></div><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;"><div id="bloop_customfont" style="margin: 0px;">(rabbit@localhost)1> {ok, Pid} = riakc_pb_socket:start_link("127.0.0.1", 8087).</div><div id="bloop_customfont" style="margin: 0px;">{ok,<0.685.0>}</div><div id="bloop_customfont" style="margin: 0px;">(rabbit@localhost)2> riakc_pb_socket:ping(Pid).</div><div id="bloop_customfont" style="margin: 0px;">** exception exit: undef</div><div id="bloop_customfont" style="margin: 0px;">     in function  riak_pb_messages:msg_code/1</div><div id="bloop_customfont" style="margin: 0px;">        called as riak_pb_messages:msg_code(rpbpingreq)</div><div id="bloop_customfont" style="margin: 0px;">     in call from riak_pb_codec:encode/1 (src/riak_pb_codec.erl, line 73)</div><div id="bloop_customfont" style="margin: 0px;">     in call from riakc_pb_socket:encode_request_message/1 (src/riakc_pb_socket.erl, line 2094)</div><div id="bloop_customfont" style="margin: 0px;">     in call from riakc_pb_socket:send_request/2 (src/riakc_pb_socket.erl, line 2077)</div><div id="bloop_customfont" style="margin: 0px;">     in call from riakc_pb_socket:handle_call/3 (src/riakc_pb_socket.erl, line 1258)</div><div id="bloop_customfont" style="margin: 0px;">     in call from gen_server:handle_msg/5 (gen_server.erl, line 585)</div><div id="bloop_customfont" style="margin: 0px;">     in call from proc_lib:init_p_do_apply/3 (proc_lib.erl, line 239)</div><div id="bloop_customfont" style="margin: 0px;"><br></div><div id="bloop_customfont" style="margin: 0px;">Do I have something wrong here? I have installed the riak-erlang-client .ez file as a RabbitMQ plugin via dependency from my riak-exchange plugin, which I’m trying to get updated to 2.0.</div><div id="bloop_customfont" style="margin: 0px;"><br></div><div id="bloop_customfont" style="margin: 0px;">Any thoughts?</div></div><br><div class="bloop_sign" id="bloop_sign_1412007387560225024"><div style="font-family:helvetica,arial;font-size:13px"><br></div><div style="font-family:helvetica,arial;font-size:13px">Thanks!</div><div style="font-family:helvetica,arial;font-size:13px"><br>Jon Brisbin</div><div style="font-family:helvetica,arial;font-size:13px">http://jbrisbin.com</div><div style="font-family:helvetica,arial;font-size:13px">@JonBrisbin | @mformonochrome</div><div style="font-family:helvetica,arial;font-size:13px"><br></div></div></body></html>