<div dir="ltr"><br><div class="gmail_quote">---------- Forwarded message ----------<br>From: <b class="gmail_sendername">Canine Chronicles</b> <span dir="ltr"><<a href="mailto:thedogatemycode@gmail.com">thedogatemycode@gmail.com</a>></span><br>Date: Wed, Jan 28, 2015 at 11:19 AM<br>Subject: Errors running rebar in a the riak project, and compiling rebar from source<br>To: <a href="mailto:rebar@lists.basho.com">rebar@lists.basho.com</a><br><br><br><div dir="ltr">I'm trying to install riak from source, and I've encountered this error:<div><br></div><div><div>Uncaught error in rebar_core: {'EXIT',<br></div><div>                               {undef,</div><div>                                [{crypto,start,[],[]},</div><div>                                 {rebar,run_aux,1,[]},</div><div>                                 {rebar,main,1,[]},</div><div>                                 {escript,run,2,</div><div>                                  [{file,"escript.erl"},{line,741}]},</div><div>                                 {escript,start,1,</div><div>                                  [{file,"escript.erl"},{line,277}]},</div><div>                                 {init,start_it,1,[]},</div><div>                                 {init,start_em,1,[]}]}}</div><div><br></div></div><div><br></div><div>In a previous thread (<a href="http://lists.basho.com/pipermail/rebar_lists.basho.com/2014-May/002017.html" target="_blank">http://lists.basho.com/pipermail/rebar_lists.basho.com/2014-May/002017.html</a>), a suggestion that worked was to install libssl-dev, and install erlang R15. I already had libssl-dev installed, but compiling erlang from source gave the following error:</div><div><br></div><div><br></div><div><div>beam/beam_emu.c:1175:5: error: label ‘lb_hipe_trap_return’ used but not defined</div><div>beam/beam_emu.c:1175:5: error: label ‘lb_hipe_trap_resume’ used but not defined</div><div>beam/beam_emu.c:1175:5: error: label ‘lb_hipe_trap_call_closure’ used but not defined</div><div>beam/beam_emu.c:1175:5: error: label ‘lb_hipe_trap_call’ used but not defined</div><div>beam/beam_emu.c:1175:5: error: label ‘lb_hipe_call_count’ used but not defined</div><div>make[3]: *** [obj/i686-pc-linux-gnu/opt/smp/beam_emu.o] Error 1</div><div>make[3]: Leaving directory `/home/memini/Downloads/erlang_src/otp_src_R15B03/erts/emulator'</div><div>make[2]: *** [opt] Error 2</div><div>make[2]: Leaving directory `/home/memini/Downloads/erlang_src/otp_src_R15B03/erts/emulator'</div><div>make[1]: *** [smp] Error 2</div><div>make[1]: Leaving directory `/home/memini/Downloads/erlang_src/otp_src_R15B03/erts'</div><div>make: *** [emulator] Error 2</div></div><div><br></div><div><br></div><div>I'm not sure where to go from here, as there doesn't seem to be any info online regarding this problem. Any help? Erlang newbie here.</div></div>
</div><br></div>