<div dir="ltr"><font face="arial, helvetica, sans-serif">Hi All, I have a 3 node cluster hosting a Riak TS database. During a query I run into a 1022 error. The characteristics of my data and other setup is below. I am trying to understand</font><div><font face="arial, helvetica, sans-serif"><br></font></div><div><font face="arial, helvetica, sans-serif">1) the error and remedy</font></div><div><font face="arial, helvetica, sans-serif">2) what are good conf setting for my case.</font></div><div><font face="arial, helvetica, sans-serif"><br></font></div><div><font face="arial, helvetica, sans-serif">Data:</font></div><div><font face="arial, helvetica, sans-serif">1 minute interval with 30 columns per minute. Indexed on time (quantum of 1d) and two other columns. <br></font></div><div><font face="arial, helvetica, sans-serif"><br></font></div><div><font face="arial, helvetica, sans-serif">Query:</font></div><div><font face="arial, helvetica, sans-serif">      avg(<some column>) where time > t1 and time < t2 and key1=<some val> and key2 =<someval></font></div><div><font face="arial, helvetica, sans-serif"><br></font></div><div><span style="font-family:arial,helvetica,sans-serif">Strangely enough, the query works when t2-t1 <= 5 days; however, for any duration longer than that I get a 1022 error (projected result of query is too big). I am using RiakTS v1.5 and it seems in this version this setting is controlled by </span><span style="font-family:arial,helvetica,sans-serif;background-color:rgb(248,248,248)"><font color="#4f4f4f"><span style="font-size:13.3294px;white-space:pre">riak_kv.query.timeseries.max_quanta_span (set to 5K/(1K actual?) ); so, is the result purely a coincidence? </span></font></span><br></div><div><span style="background-color:rgb(248,248,248)"><font color="#4f4f4f" face="arial, helvetica, sans-serif"><span style="font-size:13.3294px;white-space:pre"><br></span></font></span></div><div><span style="background-color:rgb(248,248,248)"><font color="#4f4f4f" face="arial, helvetica, sans-serif"><span style="font-size:13.3294px;white-space:pre">w.r.t 1022 error: Docs say that max_returned_data_size is the parameter I can tune to fix this issue.</span></font></span></div><div><span style="background-color:rgb(248,248,248)"><font color="#4f4f4f" face="arial, helvetica, sans-serif"><span style="font-size:13.3294px;white-space:pre">However, it seems this parameter controls the </span></font></span><span style="font-size:13.3294px;white-space:pre;color:rgb(79,79,79);font-family:arial,helvetica,sans-serif;background-color:rgb(248,248,248)">size of the result; so, Is there any reason I get this error code on a avg calculation? </span></div><div><span style="font-size:13.3294px;white-space:pre;color:rgb(79,79,79);font-family:arial,helvetica,sans-serif;background-color:rgb(248,248,248)"><br></span></div><div><span style="font-size:13.3294px;white-space:pre;color:rgb(79,79,79);font-family:arial,helvetica,sans-serif;background-color:rgb(248,248,248)">I have not changed the max_returned_data_size setting to see if it will fix the issue; just trying to understand whether this is the size of the data scanned or size of the data returned</span><br></div><div><font face="arial, helvetica, sans-serif"><br></font></div><div><span style="font-family:arial,helvetica,sans-serif">Finally, I have 1m interval data for a year and in a production setting I would like to go to 10s data for 3 years; Are there any recommended value for quanta I should be using?</span><br></div><div><span style="font-family:arial,helvetica,sans-serif"><br></span></div><div><span style="font-family:arial,helvetica,sans-serif">I would really appreciate any insight/input into the issue and any recommendation on how to configure the table.</span><br></div><div><font face="arial, helvetica, sans-serif"><br></font></div><div><font face="arial, helvetica, sans-serif">Best,</font></div><div><font face="arial, helvetica, sans-serif">C.S.N</font></div></div>